magnify
Home Cisco VLAN Temel Konfigurasyonu – 2 (VTP Domain yapılandırmaları)
formats

VLAN Temel Konfigurasyonu – 2 (VTP Domain yapılandırmaları)

Tarih 23 Şubat 2009 yazar içinde Cisco

İlk makalemizde VLAN Temel Konfigürasyonundan bahsetmiş ve sizlere 2 switch arasındaki VLAN haberleşmesi için gerekli olan konfigürasyonu sunmuştum. Bu yazımda ise 2 veya daha fazla switch arasında VTP domain oluşturulmasını ele alacağım.

Kullandıklarım,

1 adet Layer2 veya Layer3 switch (VTP Server modda çalışacak)

4 adet Catalyst 2950 Switch

4 adet Server

Topolojimi bir bina içerisinde her biri için farklı serverların kullanıldığı 4 farklı Departmanı ele alarak oluşturuyorum.  Yapı itibariyle 5 katlı olan bu binamızda en üst katı sistem odası olarak ayırdım. Geri kalan katların yerleşimine müdürümüz karar verdi böylece 4.kat Muhasebe 3. kat Finans 2. kat Satış 1. kat Güvenlik departmanı olarak belirlendi. Böyle bir yapı için bizden istenen her departmanın kendine ait bir switchi ve kendisine ait bir VLAN’a sahip olması yönündeydi. Bu aşamada içinizi rahatlatacağım, her katta farklı switch ve VLAN’lar olmasına rağmen, siz ileride bir gün her hangibir departmandaki kullanıcıyı farklı departmanın olduğu bir katta çalıştırsanız bile kullanıcının PC’sini o katta bulunan switch üzerinden kendi çalıştığı departmana ait VLAN’a dahil edebilirsiniz. Böylelikle kullanıcı Fiziksel olarak farklı bir departmanda bulunsa bile network kablosu, daha önceki kullandığı VLAN’a dahil olan porta takılı olacağı için çalışmakta olduğu departmandaki kullanıcı PC’lerinden gelen Broadcast paketlerinden etkilenmeyecek hatta bu PC’lere erişemeyecektir. Yani biz istemediğimiz sürece sadece kendi dahil olduğu VLAN içerisinde haberleşecektir.

clip_image002

Şimdi konumuza geri dönelim farklı serverların olduğu en üst kattaki sistem odamıza 1 adet 3560 Layer 2 ve diğer tüm katlara Catalyst 2950 24 portluk switch koydum sırasıyla gidecek olursak;

I) Sistem odasındaki 3560 L2 switch’in VTP modunun server yapılması, VTP Domain adı ve şifresinin belirlenmesi, departmanlar için VLAN’ların oluşturulması, Switch üzerindeki “diğer switchlere VLAN bilgisini dağıtacak olan” Trunk portunun yapılandırılması.

II) Diğer katlardaki 2950 switchlerin VTP modunun Client yapılması, VLAN ve VTP Domain bilgisini iletecek olan trunk portunun yapılandırılması.

Şimdi VTP modu server olarak yapılandıracağım. Belli bir düzende gitmek ve karmaşıklığı azaltmak için konfiurasyona en üst kattan başlıyorum.

Bildiğimiz gibi standartta tüm switchler server modda gelmektedir bunun için biz 3560 L2 switch dışındaki tüm Catalyst 2950 switchlerin VTP modunu client olarak yapılandıracağımızı unutmayalım.

1) 3560 L2 Switch VTP Domain Ayarlarının yapılması,

Önce switchimize diğer switchlerin fiziksel bağlantısını yapmadan önce notebook yada bilgisayar ortamından konsol yardımı ile switchimize bağlanıyoruz.

clip_image004

Gördüğünüz gibi bir alışkanlık olarak ilk önce hostname komutu ile switch’imize 3560L2 ismini verdim. Şimdi VTP Domain ayarlarına geçelim. Switchimizin adını değiştirdikten sonra kaldığımız yerden devam ediyoruz.

3560L2(config)#vtp mode server

Device mode already VTP SERVER.

3560L2(config)#vtp domain cozumpark

Changing VTP domain name from NULL to cozumpark

3560L2(config)#vtp password cozumpark

Setting device VLAN database password to cozumpark

3560L2(config)#wri mem

Building configuration…

[OK]

Yukarıda gördüğünüz gibi konfigürasyon modundayken

vtp mode server” komutu ile switchin VTP modunu server yaptık. Daha sonra

vtp domain cozumpark” komutu ile switch üzerinde cozumpark domainimizi oluşturduk

vtp password cozumpark” komutu ile switch üzerinde kurduğumuz cozumpark domainine cozumpark diye parola verdik.

Şimdi diğer switchlerin VTP domain ile haberleştirecek olan Trunk portunu belirleyip ve ayarlarını yapalım;

3560 L2 switch üzerinde 2 adet Gigabit Ethernet portu mevcut ben hızdan kazanmak için Gigabit Ethernet 0/1 arayüzünü Trunkport olacak şekilde ayarlıyorum. Şimdi;

3560L2>en

3560L2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

3560L2(config)#interface gigabitEthernet 0/1

3560L2(config-if)#switchport mode trunk

3560L2#(config-if)#description Trunk Porttur

Şimdi açıklayarak anlatmak istiyorum Konfigurasyon moda girerek VTP Server modda çalışan switchimizin Trunk yapmasını istediğimiz Gigabit Ethernet 0/1 portunun switchport mode trunk olacak şekilde aynı isimli komutla ayarlamış olduk. Daha sonra description Trunk Porttur diyerek bu porta ait içerik bilgisi yazmış olduk. Bu sayede show running-config komutunu yazdığımızda karşımıza çıkacak olan arayüz listesinde Gigabit Port altında açıklamasını görmüş olacağız.

!

interface GigabitEthernet0/1

description Trunk Porttur

switchport mode trunk

!

gibi.

Bu kısıma kadar herşey anlaşılır sanırım. Şimdi gelelim 4-3-2 ve 1. katlardaki 2950 switchlerimizin yapılandırılmasına. Bu ayarlar tüm client switchlerimiz için aynı olacaktır.

Öncelikle switch’imizi açıyoruz ve

Switch>en

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname Muhasebe

Muhasebe(config)#vtp mode client

Setting device to VTP CLIENT mode.

Muhasebe(config)#vtp domain cozumpark

Changing VTP domain name from NULL to cozumpark

Muhasebe(config)#vtp password cozumpark

Setting device VLAN database password to cozumpark

Muhasebe(config)#interface fa0/24

Muhasebe(config-if)#switchport mode trunk

Muhasebe(config-if)#description Trunk Porttur

Muhasebe(config-if)#exit

Muhasebe(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Muhasebe#wri mem

Building configuration…

[OK]

Muhasebe#

Şunu belirtmek istiyorum ilk olarak switch’e bağlanıp hostname komutu ile switchin adını muhasebe olarak değiştirdim. Daha sonra Konfigürasyon modundayken vtp mode client yazarak switchimizi client moda alıyoruz. Client olarak VTP Domainine dahil olmasını istediğimiz bu switchimizi, server switchimize yazdığımız komutların birebir aynısını yazıyoruz. Aslında ben bu aşamayı bluetooth’ta iki telefonun birbirini görmesi için yaptığımız işleme benzetiyorum.

Şimdi unutmadan ufak bir işlemimiz kaldı client switchlerde Trunk port iki tane olmak zorunda yani bu konfigürasyonunu yapmış olduğumuz switchin 24. portunu trunk yapmıştık şimdi de 23. portunu da Trunk yapıp diğer client switch ile haberleşebilmesi için yapılandıracağız.

Muhasebe(config)#interface fa0/23

Muhasebe(config-if)#switchport mode trunk

Muhasebe(config-if)#description Trunk Porttur

Muhasebe(config-if)#exit

Bu yapıda client switch’ler üzerindeki tüm 24. portlar alıcı, 23.Trunk portları ise bir sonraki client switche aktarıcı olarak yapılandırdım.

clip_image006

Yukarıda gördüğünüz yapıyı bir program aracılığı ile çizdim ancak site kuralları gereği ismini vermek istemiyorum. Görüdüğünüz gibi en üst katta, içerisinde 4 adet server ve ana switchimiz olan Cisco 3560’ın bulunduğu sistem odası ve alt katlarda herbirine 5 desktop pcnin bağlı olduğu VTP client modda çalışacak olan Cisco 2950 switchlerimizi yerleştirdim. Kısaca nasıl bağlandıklarından bahsedeyim Server ve Desktop PC’ler standart Category5 veya Category6 kablo ile Switchlerin portlarına bağlanır. Ana switch olan 3560 ile 4.kattaki 2950 switch arasındaki Trunk portlarını cat5 kablo ile birleştirdim isterseniz cross-over kabloyla da bağlayabilirsiniz. Son olarak 4. kat ve 1. kat arasında bulunan tüm 2950 switchler arası cross-over kablo ile bağladım.

Evet, şu ana kadar yaptığımız tüm işlemler ile aktif cihazları yani switchleri 1 server ve 4 client switch olacak şekilde VTP domain yapısına aldık. Bu sayede server switch olan 3560 üzerinde VLAN oluşturduğumuzda client olan switchler bundan haberdar olacak ve client switch üzerinde portları VLAN’a atamak dışında bir işlem yapmamıza gerek kalmayacak. Şimdi yapacağımız işlemler bu yapının amacımıza uygun hale getirilmesini sağlayacak.

Server switch olan 3560 üzerinde Muhasebe, Finans, Pazarlama ve Güvenlik VLAN’larımızı yaratalım.

3560L2>en

3560L2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

3560L2(config)#vlan 2

3560L2(config-vlan)#name Muhasebe

3560L2(config-vlan)#exit

3560L2(config)#vlan 3

3560L2(config-vlan)#name Finans

3560L2(config-vlan)#exit

3560L2(config)#vlan 4

3560L2(config-vlan)#name Pazarlama

3560L2(config-vlan)#exit

3560L2(config)#vlan 5

3560L2(config-vlan)#name Guvenlik

3560L2(config-vlan)#exit

3560L2(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

3560L2#wri mem

Building configuration…

[OK]

Şimdi show vlan komutu ile vlan tablomuzu görelim.

clip_image008

Şimdi artık VTP Domainimiz aktif olduğu için hangi switch’te show vlan yazarsanız yazın bu listeyi aynı şekilde göreceksiniz. Yani 3560 üzerinde yeni bir VLAN yaratılması ve silinmesi durumunda güncel bilgi VTP Domain yoluyla diğer switchlere de aktarılacaktır.

Bu yapıda sistem odamızda bulunan serverlarımızı yarattığımız VLAN’ların üyesi yapalım. Serverlarımız networke bağlı olduğu 3560 switch üzerinde olduğu için bu switch üzerinde aşağıdaki işlemleri yapmalıyız,

3560L2> en

3560L2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

3560L2(config)#interface fa0/1

3560L2(config-if)#switchport access vlan 2

3560L2(config-if)#no shutdown

3560L2(config-if)#interface fa0/2

3560L2(config-if)#switchport access vlan 3

3560L2(config-if)#no shutdown

3560L2(config-if)#interface fa0/3

3560L2(config-if)#switchport access vlan 4

3560L2(config-if)#no shutdown

3560L2(config-if)#interface fa0/4

3560L2(config-if)#switchport access vlan 5

3560L2(config-if)#no shutdown

3560L2(config-if)#

Gördüğünüz gibi 1 den 4’e kadar olan tüm interface yani arayüzlerin konfigurasyonuna girip iletişimlerini

Arayüz                      VLAN ID

(fa0/1                   ->            VLAN 2) Muhasebe

(fa0/2                   ->            VLAN 3) Finans

(fa0/3                   ->            VLAN 4) Pazarlama

(fa0/4                   ->            VLAN 5) Güvenlik

Bu aşamada ana switchimize bağlı olan tüm serverlar kendilerine ait VLAN’ların üyesi oldular.

Tüm serverların DHCP ile IP dağıtacak şekilde konfigure edildiğini farzedin, merak etmeyin artık serverlarınız aynı switche bağlı olmasına rağmen farklı VLAN’lara üye oldukları için DHCP sorgulamaları sadece kendi VLAN’ları içerisinde gerçekleşecektir. Biz istemedikçe farklı VLAN’lar birbirleri ile haberleşmeyeceklerdir.

Şimdi en alt kata inerek Güvenlik departmanındaki 1 adet Client PC’mizi 2950 client switchimizin 1.portuna bağlayalım ve Güvenlik VLAN’ı yani VLAN 5’e dahil edelim sonrada VLAN 5’e dahil olan GVN-DC’den IP almasını sağlayalım.

Guvenlik>en

Guvenlik#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Guvenlik(config)#interface fa0/1

Guvenlik(config-if)#switchport access vlan 5

Guvenlik(config-if)#no shutdown

Guvenlik(config-if)#exit

Guvenlik(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Guvenlik#wri mem

Building configuration…

[OK]

Guvenlik#

İşte oldu, Güvenlik departmanındaki PC’mizi 2950 Client modda çalışan switchimizin 1. portuna taktık ve sonrasında bu portun ayarlarına girip, switchport access vlan 5 yazarak, bu port üzerine hangi PC’yi takarsak takalım artık bu portun VLAN 5 üzerinden haberleşecek şekilde ayarlamış olduk. Dolayısıyle siz VLAN 5’e dahil olan GVN-DC’niz üzerinde DHCP yapılandırması yaptıysanız ve bu VLAN’a sonradan dahil olacak client pclerin IP konfigurasyonu otomatik alacak şekilde yapılandırıldıysa, GVN-DC üzerinden yani DHCP üzerinden IP almaya başlayacaklardır ve bu durumdan switch üzerinde bulunan diğer VLAN’lar etkilenmeyeceklerdir. Bunun mantığında (Her VLAN kendi kendine broadcast domaindir) sözü yatmaktadır.

Arkadaşlar ne yazık ki makalemin sonuna gelmek zorundayım. Konfigurasyonu Tek server switch, tek client switch, tek server, tek client pc yapılandıracak şekilde anlattım. Tüm topolojiyi etkin kullanabilmeniz için client switch yapılandırmasını diğer switchlere de uygulayarak yapabilir ve diğer tüm pc’lerin bağlanacağı switchler üzerindeki ara yüzleri, üyesi yapmak istediğiniz VLAN’lana dahil ederek yapabilirsiniz.

Hepinize iyi çalışmalar diyorum.

Saygılarımla

Mustafa VANGÖL

 
 Share on Facebook Share on Twitter Share on Reddit Share on LinkedIn
VLAN Temel Konfigurasyonu – 2 (VTP Domain yapılandırmaları) için yorumlar kapalı  comments 
© Hakan Uzuner
credit